ConnectIt compatibility with QuoteWerks v5.0

We are pleased to announce that all ConnectIt products are fully compatible with the new QuoteWerks v5.0 release. This includes both Products which integrate Sage 50 Accounts, Sage 200 ERP, Pegasus Opera, Sage MAS90/200 ERP, websites, etc. plus our QuoteWerks Workflow add-ons and bespoke / custom developed offerings. No upgrades are required to ConnectIt Products – all features and functions are expected to work as-is following an upgrade to your QuoteWerks software.

We will be doing some upgrades to the various ConnectIt offerings to support new fields which are present in this new release; these will be released and announced in due course. If however there is a particular field or new feature that you are keen to have available in ConnectIt, then please do not hesitate to get in touch with the development team.

Tags: , ,

Leave a Reply

You must be logged in to post a comment.